Help talk:Installing

From Openbox

Revision as of 03:30, 5 January 2008 by Mikachu (Talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

In 64bit Fedora Core 6(and possibly other x86_64 platforms) you will need to copy the required libraries to /usr/lib64/ to avoid shared library errors Not sure if this is the best way to do this or not but...it works (careful)

The output of: ldd /usr/bin/openbox should say it is missing libobrender.so, libobparser.so, etc if not, then your problem isnt with libraries.

Otherwise, Open your console, become root, copy /usr/lib/libob* to /usr/lib64/, remove libob* in /usr/lib/ folder...

the following commands should do the trick(careful with the wildcards):

1.) su

2.) cp /usr/lib/libob* /usr/lib64/

3.) rm /usr/lib/libob*

Shouldn't give you any more trouble, careful with the wildcards (as always).

Hours of fiddling suddenly solved with 3 lines :-)

Oh, and if you were getting errors for missing apps as well, then you might want to comment out those lines in your /etc/xdg/openbox/autostart.sh

Enjoy OpenBox v3.4 :-)

Personal tools