ObConf:About

From Openbox

(Difference between revisions)
Jump to: navigation, search
(Screenshots)
(Installation)
Line 9: Line 9:
 
== Installation ==
 
== Installation ==
 
You'll need the following:
 
You'll need the following:
* openbox from subversion
+
 
  * svn co svn://svn.icculus.org/openbox/trunk/ openbox
+
* openbox from subversion
  * cd openbox; ./configure --prefix=/usr; make; make install [make install requires root privileges]
+
 
* [http://ruby-gnome2.sourceforge.jp/ ruby-gnome2] 0.16.0 or cvs.
+
 
  * FOR 0.16.0 ONLY: edit /usr/lib/ruby/site_ruby/1.8/libglade2.rb
+
svn co svn://svn.icculus.org/openbox/trunk/ openbox
    * find (should be line 42)
+
cd openbox; ./configure --prefix=/usr; make; make install [make install requires root privileges]
{{{
+
 
#!ruby
+
 
if signal_proc
+
* [http://ruby-gnome2.sourceforge.jp/ ruby-gnome2] 0.16.0 or cvs.
}}}
+
** FOR 0.16.0 ONLY: edit /usr/lib/ruby/site_ruby/1.8/libglade2.rb
    * add guard_source_from_gc(source) so that it looks like
+
*** find (should be line 42)
{{{
+
#!ruby
#!ruby
+
if signal_proc
if signal_proc
+
*** add guard_source_from_gc(source) so that it looks like
    guard_source_from_gc(source)
+
#!ruby
}}}
+
if signal_proc
* ruby-gettext
+
    guard_source_from_gc(source)
* obtain and install obconf
+
 
  * svn co http://svn.l3ib.org/obconf/trunk obconf
+
* ruby-gettext
  * cd obconf; sudo ruby setup.rb [requires root privileges]
+
* obtain and install obconf
* enjoy life
+
** svn co http://svn.l3ib.org/obconf/trunk obconf
  * run obconf2
+
** cd obconf; sudo ruby setup.rb [requires root privileges]
 +
* enjoy life
 +
** run obconf2
  
 
== Screenshots ==
 
== Screenshots ==

Revision as of 19:53, 19 May 2007

Contents

Features

  • Real theme previews generated using libobrender
  • Written in Ruby, not a pain in the ass to add new options to it (not 500 callback functions like the C version)

Caveats

  • Lags behind openbox development either because I'm lazy or because of school.
  • Ubuntu has an old (buggy) version of ruby-gnome2 in its repositories that doesn't work well with Obconf.

Installation

You'll need the following:

  • openbox from subversion


svn co svn://svn.icculus.org/openbox/trunk/ openbox
cd openbox; ./configure --prefix=/usr; make; make install [make install requires root privileges]


  • ruby-gnome2 0.16.0 or cvs.
    • FOR 0.16.0 ONLY: edit /usr/lib/ruby/site_ruby/1.8/libglade2.rb
      • find (should be line 42)
#!ruby
if signal_proc
      • add guard_source_from_gc(source) so that it looks like
#!ruby
if signal_proc
    guard_source_from_gc(source)
  • ruby-gettext
  • obtain and install obconf
  • enjoy life
    • run obconf2

Screenshots

File:Obconf Theme.png

File:Obconf Appearance.png

File:Behaviour.png

File:Obconf Desktops.png

File:Obconf Dock.png

Personal tools